Gemfile error

I was trying to run the server and i keep getting this error, can't really figure out my around this [!] There was an error parsing `Gemfile`: You cannot specify the same gem twice with different version requirements. You specified: sass-rails (~> 5.0.4) and sass-rails (>= 5.0.4). Bundler cannot continue. # from /Users/Enoch/Desktop/Streetlot/Gemfile:25 # ------------------------------------------- # gem 'sdoc', '~> 0.4.1', group: :doc > gem 'sass-rails', '>= 5.0.4' # # ------------------------------------------- this is my gem file source 'https://rubygems.org' # Bundle edge Rails instead: gem 'rails', github: 'rails/rails' gem 'rails', '4.2.4' # Use sqlite3 as the database for Active Record gem 'sqlite3' # Use SCSS for stylesheets gem 'sass-rails', '~> 5.0.4' # Use Uglifier as compressor for JavaScript assets gem 'uglifier', '>= 2.7.2' # Use CoffeeScript for .coffee assets and views gem 'coffee-rails', '~> 4.1.0' # See https://github.com/rails/execjs#readme for more supported runtimes # gem 'therubyracer', platforms: :ruby # Use jquery as the JavaScript library gem 'jquery-rails' # Turbolinks makes following links in your web application faster. Read more: https://github.com/rails/turbolinks gem 'turbolinks' # Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder gem 'jbuilder', '~> 22.3.2' # bundle exec rake doc:rails generates the API under doc/api. gem 'sdoc', '~> 0.4.1', group: :doc gem 'sass-rails', '>= 5.0.4' # Use ActiveModel has_secure_password # gem 'bcrypt', '~> 3.1.7' # Use Unicorn as the app server # gem 'unicorn' # Use Capistrano for deployment # gem 'capistrano-rails', group: :development group :development, :test do # Call 'byebug' anywhere in the code to stop execution and get a debugger console gem 'byebug' end group :development do # Access an IRB console on exception pages or by using <%= console %> in views gem 'web-console', '~> 2.2.1' # Spring speeds up development by keeping your application running in the background. Read more: https://github.com/rails/spring gem 'spring' end

Posted almost 4 years ago by Enoch Ilufoye
Posted almost 4 years ago by Alex Yang

Hi Enoch,

In the future, please post course-specific troubleshooting questions in the discussion thread beneath the video. This will give me more context around the issue and can help other students benefit as well.

You're seeing this error because you've listed the 'sass-rails' gem twice in your Gemfile. Your app doesn't know which version it should install. To fix, just remove one of the references, save, run 'bundle install', and restart your Rails server. Hope that helps!

Best,
Alex

1
Posted almost 4 years ago by Enoch Ilufoye

Thanks it worked

1